SyMenu Forum

SyMenu

 

HomeTroubleshooting & Bug Reports

If you found a bug post here your report.

App not recognizing programs & now won't even run Messages in this topic - RSS

conceptualclarity
conceptualclarity
Posts: 1


29 days ago
I have the large majority of programs on my computer through SyMenu. Sometime back, probably over a year ago, a Windows 10 update wrecked the SyMenu application so that I could no longer run it. Sometimes I might see SyMenu.exe briefly on Process Explorer but it would quickly disappear before launching. So I have had to access through File Explorer the SyMenu programs I did not have on Quick Launch or the system tray.

I had created a special folder on my laptop called "My Software" for the purpose of protecting programs from being molested with permissions changes and other mischief by Windows updates as it became increasingly clear to me that the philosophy behind Windows 10 was that my computer belonged to Microsoft rather than to me and that the job of Windows 10 was to protect the computer from being utilized freely by me, its owner and only user. For a while this effort on my part worked pretty well, and SyMenu was among the programs I put in My Software.


A few days ago I downloaded the SyMenu zip file from your home page in the effort to restore the application. (This was prompted by something going wrong causing Brave Portable browser to crash every time I open it.) I copied the folders and files of the new download to my existing SyMenu folder within My Software, implementing replace for previous folders and files of the same name.


It could have been when I was doing the copy but I think it was afterward when I sought to run the application that Windows Defender Smart Screen interfered.


I clicked on "Run anyway" and it did run.


But as you can see it did not recognize the big roster of portable programs I had on my computer in the SyMenu folder.

When I closed the application and tried to restart it from Quick Launch I was surprised to encounter the SmartScreen block again, and this time when I clicked on "Run anyway" it didn't work. Nor did it work when I clicked "Run as administrator" from File Explorer. It would only show up briefly on Process Explorer and Task Manager, flashing "Suspended" Status on the latter. Upon checking Security under Settings, the Protection History for the AV and ransomware protection said no recent actions. Adding SyMenu.exe to apps allowed through Controlled folder access did not help. PUA blocking was never on. Even turning SmartScreen off did not stop the pattern of SyMenu.exe quickly aborting. i have logs of these things available through Event Viewer.

I tried running SyMenu.Admin.exe from the folder with the Run as administrator right click. I got the SmartScreen popup again, and clicked "Run anyway". It lingered a bit longer but still aborted.

I tried the advice at How To Whitelist Apps In The SmartScreen On Windows 10 (addictivetips.com), but I don't see the message and checkbox described there.



In the previous round when I lost the ability to run the SyMenu application I don't remember encountering the SmartScreen popup,

Can I get any help on regaining the ability to run the SyMenu application and, if that is successful, on getting the application to recognize the many programs that are already there in its folder?



Computer: Hewlett-Packard HP Pavilion Notebook
CPU: Intel Core i3-5010U (Broadwell U, F0)
2100 MHz (21.00x100.0) @ 2095 MHz (21.00x99.8)
Motherboard: Hewlett-Packard 8093
BIOS: F.03, 03/31/2015
Chipset: Intel Broadwell-U PCH-LP (Premium)
Memory: 8192 MBytes @ 798 MHz, 11-11-11-28
- 8192 MB PC12800 DDR3 SDRAM - Samsung M471B1G73QH0-YK0
Graphics: Intel Broadwell-U GT2 - Integrated Graphics [F0] [Hewlett-Packard]
Intel HD Graphics 5500, 1024 MB
Drive: HGST HTS545050A7E680, 488.4 GB, Serial ATA 6Gb/s @ 6Gb/s
Drive: hp DVDRW GUB0N, DVD+R DL
Sound: Intel Broadwell PCH-LP - High Definition Audio Controller [B2]
Network: RealTek Semiconductor RTL8723BE Wireless LAN PCIe Adapter
Network: RealTek Semiconductor RTL8101/2/3 Family Fast Ethernet NIC
OS: Microsoft Windows 10 Home (x64) Build 19043.2130 (21H1)
AV: Windows Defender

edited by conceptualclarity on 04/11/2022

link
Gianluca
Gianluca
Administrator
Posts: 1087


29 days ago
Gianluca
Gianluca
Administrator
Posts: 1087
Well... it seems that Windows has made a mess with your system. I've never heard so many problems all together. Are you sure your system is not infected by some kind of virus/malware/ransomware? Besides Windows, naturally.


Anyway the problem with SyMenu seems similar to the problem you can have downloading any file from the Internet.

In the SyMenu manual for example I explained what you should do when this kind of issue plagues the SyMenu plugins (read https://www.ugmfree.it/SyMenuManual.aspx#SyMenuPluginBlocked).


So assuming the problem is similar, try this procedure:
  • download the last SyMenu zip package;
  • right click the zip and unblock the file (same way I explained for the plugins);
  • unzip SyMenu in an empty folder;
  • try to use it a bit, download something, close it and re-open it.

If everything works fine the reason for your tribulations is that you have some of the unzipped files still locked. Because, in the Microsoft world, the Internet is evil and everything you download from there can damage your PC... ops sorry their PC smile.


If this is the cause for all your problems you have a big big problem because you should unlock all the SyMenu files and, I fear, any package SyMenu has ever downloaded could be infected with the same disease (in technical terms the disease it's called alternate stream).
But the mighty Nir Softer is always here to help us. If you have problem with the alternate streams thing, you can use the AlternateStreamView program (you can find it in the NirSoft suite or here https://www.nirsoft.net/utils/alternate_data_streams.html) that is able to heal all your sick files in batch.

Let me know if the solution is suitable for your system, otherwise I can think of something else.
link



UGMFree © 2002-2022
PayPal BTC TON